Как извлечь год, месяц и день из даты

В этой статье мы разберём ряд формул для извлечения из числовой записи даты таких параметров как год, месяц, месяц прописью, день, день недели и день недели прописью.

Пример, который мы будем рассматривать, можно скачать по ссылке выше.
Так же есть видео на случай если Вам так будет удобнее.

Для извлечения года из даты, воспользуемся следующей одноимённой формулой:

«=ГОД(А1)»

В случае с извлечением месяца, так же в Microsoft Excel имеется одноимённая формула:

«=МЕСЯЦ(А1)»

Усложним задачу — с помощью формулы извлечём месяц прописью:

«=ИНДЕКС({«январь»;»февраль»;»март»;»апрель»;»май»;»июнь»;»июль»;»август»;»сентябрь»;
«октябрь»;»ноябрь»;»декабрь»};МЕСЯЦ(A1))«,

где

  • «{«январь»;»февраль»;»март»;»апрель»;»май»;»июнь»;»июль»;»август»;»сентябрь»;
    «октябрь»;»ноябрь»;»декабрь»}
    » — массив, то есть диапазон текстовых значений месяцев, из которых Excel будет извлекать соответствующее нашему примеру;
  • МЕСЯЦ(A1) — строка в массиве, из которой нужно возвращать значение, то есть порядковый номер месяца, с помощью которого Excel поймёт какой по порядку месяц извлекать из массива.

С помощью функции ДЕНЬ, извлечём соответствующий порядковый номер дня из нашего примера:

«=ДЕНЬ(A1)»

Нам так же доступна функция, с помощью которой мы можем извлечь номер дня недели:

«=ДЕНЬНЕД(A1)»

Как и в случае с месяцем, извлечём формулой день недели прописью при помощи уже знакомой нам функции ИНДЕКС:

«=ИНДЕКС({«понедельник»;»вторник»;»среда»;»четверг»;»пятница»;»суббота»;»воскресенье»};
ДЕНЬНЕД(A1))
»

где

«{«понедельник»;»вторник»;»среда»;»четверг»;»пятница»;»суббота»;»воскресенье»}» — массив, то есть диапазон текстовых значений дней недели, из которых Excel будет извлекать соответствующий нашему примеру;

«ДЕНЬНЕД(A1)» — строка в массиве, из которой нужно возвращать значение, то есть порядковый номер дня недели, с помощью которого Excel поймёт какой по порядку день недели извлекать из массива.

 

 

Скачать пример

Add a Comment

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Сообщить об опечатке

Текст, который будет отправлен нашим редакторам: