Как сравнить два диапазона с помощью условного форматирования

В одной из прошлых статей мы уже рассматривали, что из себя представляет условное форматирование в Microsoft Excel.
Рассмотрим, как сравнить два диапазона значений с помощью условного форматирования.

Для этого выделим диапазон значений первого столбца — A2:A16.

Во вкладке Главная в группе стиле выберем Условное форматирование.

В выпадающем списке перейдём в Создать правило…
Это необходимо, потому что готовые правила в Excel нам не подходят — они для более простых задач.

Во всплывающем окне запишем формулу:

=СЧЁТЕСЛИ($C$2:$C$16;A2)=0,

где

  • «СЧЁТЕСЛИ()=0» — функция, которая подсчитывает количество значений, удовлетворяющих заданному условию;
  • $C$2:$C$16 — аргумент функции, указывающий, в каком диапазоне вести подсчёт;
  • A2 — аргумент функции, указывающий на критерий, по которому должен вестись подсчёт, т.е. функция считает все ячейки, которые равны значению ячейки A2.

Функция читается так: если количество ячеек в диапазоне C2:C16, равных значению ячейки A2, равно нулю, то с помощью условного форматирования выделить эти ячейки.
Цвет выделения мы зададим ниже.

Чтобы задать цвет выделения ячеек, в том же окне перейдём в Формат…
А во вкладке Заливка выберем интересующий нас цвет.
ОК.

У нас получились следующие настройки условного форматирования.

После применения всех настроек, столбец A примет следующий окрашенный вид.
Видно, что все неокрашенные ячейки — это значения, которые имеют совпадения в столбце C.

Проделаем те же самые действия по отношению к столбцу C, чтобы найти совпадения и там.

В результате наших действий, мы получим таблицу, по которой легко найти все уникальные и повторяющиеся значения.
Визуально всё понятно, поэтому и нет необходимости вручную искать совпадения в больших таблицах.

Теперь вы знаете, как сравнить два диапазона.
Обязательно закрепите новые знания практикой, чтобы хорошо усвоить материал!

Скачать пример

Больше полезных видеоуроков на нашем YouTube канале.
Если у Вас возникли вопросы или просто хотите поделиться мнением, напишите в комментариях к записи.

Add a Comment

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Сообщить об опечатке

Текст, который будет отправлен нашим редакторам: